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AardRock
Some Rights Reserved

Attribution-NoDerivs-NonCommercial 1.0 Netherlands

You are free:

 to copy, distribute, display, and perform the work

under the following conditions:

Attribution.
You must give the original author credit.

Non-commercial.
You may not use this work for commercial purposes.

Share alike.
If you alter, transform, or build upon this work, you may distribute the 
resulting work only under a license identical to this one.

 For any reuse or distribution, you must make clear to others the license terms of this work.

 Any of these conditions can be waived if you get permission from the copyright holder.

Your fair use and other rights are in no way affected by the above
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Change History

Date Version Authors Description
Mar 05, 2006 0.1 Martien van Steenbergen ✦ First draft.

Mar 13 2006 0.2 Martien van Steenbergen ✦ Added section on AutoFilter.
✦ Processed feedback from Martijn and 

Chris.

Apr 11 2006 0.3 Martien van Steenbergen ✦ Fixed some typos and layout, version 
number.

✦ Split AutoFilter part into separate stories
✦ Added splash screen behaviour.
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About the Cheetah User Manual

TODO Synchronize and converge the current version of the software and the user manual. Requires a 
synchronization meeting up front. Until then, you can expect inconsistencies.

The User Manual is the ever evolving foundation for development of Cheetah.

Discussions (during meetings and in e-mails), and request for enhancements (either explicitly or 
implicitly, e.g. during User Feedback Tests) are reflected in this User Manual.

Color-coded requirements and Cheetah versions

Cheetah 1.0 will include all agreed upon requirements. Cheetah 1.0 is comprised by two 
components: the Cheetah 1.0 software and the Cheetah 1.0 User Manual, both of which must be 
in full synchronization in order to accept Cheetah 1.0. Any inconsistency is considered a bug and 
requires either or both to be adapted until full synchronization is achieved.

In the running text, stories are treated as implementation units and are limited to a single 
sentence, so never cross the sentence boundary. As such, stories are the unit of implementation, 
acceptance and payment.

Grey text denotes stories yet to be implemented.

Normal black text denotes implemented stories and ready to be accepted.

Bold text denotes accepted stories.

Underlined text denote new stories that are considered important because they add functional 
value or improve the user experience. These new requirements are pending a decision to include 
them in some future version of Cheetah 
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1 Welcome to Cheetah

Cheetah is an smart and simple tool that makes your life as a diabetic easier and more fun. 
Cheetah allows you to keep track of your glucose levels, nutrition, insulin doses, and health. When 
you use Cheetah intensively, Cheetah will start giving suggestions for food and insulin doses. 
When you allow Cheetah to share your data with friends and peers, these suggestions become 
even more accurate, leading to an increasing stable and healthy glucose level.

If you’ve received an e-mail form a friend inviting you to join Cheetah, simply click on the link in 
the email and follow the instructions for downloading and installing the software. After 
installation, Cheetah will guide you to personalize your configuration. 

If Cheetah doesn't sound like it's for you, feel free to delete your version. If you change your mind 
in the future, don't worry! Cheetah will still be there, waiting for you to rejoin. 

It is our mission to help you create a better way to work with diabetes, even make it fun

Installing Cheetah

System Requirements

Cheetah works on the following platforms:
• Windows 2000 SP3
• Windows 98 (Second Edition)
• Windows XP SP2
• Mac OS X 10.4

Minimum performance, memory and disk space requirements:
• Intel Pentium PC 500 MHz or better
• 128 MB RAM
• 20 MB of free disk space for the application

To Install Cheetah:

1 To install Cheetah, download the installion program from http://cheetah.aardrock.com/
download/.

2 Next, double-click in the installation icon named ‘AardRock-Cheetah-version’ and follow the 
instructions of the installation program.

Technical Support

The current version of Cheetah is unsupported since it is still in full development. However, we 
welcome any and all feedback at feedback@cheetah.aardrock.com.
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The Cheetah Window

When you start Cheetah, the Cheetah splash screen will show almost immediately (within one 
second):
• in parallel to loading and launching the Cheetah main window itself
• the splash screen shows while Cheetah is loading and for at least 3 seconds (time is stored in 

Cheetah configuration file)
• to display the splash screen (in a window), choose Cheetah > About Cheetah
• the splash screen shows:

- company logo
- product name
- release (e.g. Cheetah Summer 2006)
- version and build number in smaller font (e.g. 2006.1.0 (215))
- copyright notice (e.g. © 2006 AardRock B.V., The Netherlands)
- clickable URL to website using default web browser (e.g. Find out more about Cheetah on 

cheetah.aardrock.com)
- single line of text showing what’s going on; last line is “Cheetah is ready.”
- all text and graphics left aligned, using a 24 pixel grid; no centered text and graphics)

The Cheetah main windows shows:
• status bar in footer of window, showing if you’re signed on or not as well as other status info 

(to be determined)
• when you are signed on, the main window shows your diabetes data, if any, the same way as 

when you last closed the application

Your personal profile

You can personalize your Cheetah version, make it yours, and make sure that it will adapt itself to 
your current situation and personal physical development.

To set your general personal information:

1 Choose Cheetah > Preferences and click My Profile.

2 Enter or change your personal information like:

first name

surname prefix e.g. “van”, “von der”, “de la”

surname

birth date

street

house number

zip code

city

state
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country

To set personal information for your diabetes care:

1 Choose Cheetah > Preferences and click My Diabetes.

2 Enter or change your personal diabetes information like: 

glucose unit mmol/l or mg/dl

named time slots default set to morning (06:00-11:00), midday (11:00-14:00), 
afternoon (14:00-18:00), evening (18:00-22:00, night 
(22:00-06:00)

carbohydrates per time slot specify your target carbohydrate intake per time slot; valid 
until the next change for this time slot

low glucose watermark lower glucose values will be highlighted

high glucose watermark higher glucose values will be highlighted

highlight color color used to highlight out of bounds values

glucose meter manufacturer

glucose meter serial number

Insulin Types

When you first start Cheetah, there is a good chance that many insulin types are already provided 
by both peers and insulin manufacturers. However, if you don’t find your typical type of insulin, 
you can add it and share it with your peers. You can specify the following insulin type information:

manufacturer e.g. Novo Nordisk

type e.g. Actrapid Penfill

units e.g. 100 IE/ml

volume e.g. 3 ml

total volume e.g. 300 IE

cartridges per box e.g. 5

basal percentage e.g. 30%

bolus percentage e.g. 70%

comment any comments you may want to add

To consult or change insulin information:

1 Choose Cheetah > Preferences and click Insulin.
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2 Change any existing information by simply typing over it.

To add a new insulin entry:

1 Choose Cheetah > Preferences and click Insulin.

2 Click the ‘+’-sign in the lower left corner of the window. A new insulin entry is created for you to 
fill in.

To remove an insulin entry:

1 Choose Cheetah > Preferences and click Insulin.

2 Select the entry you want to remove and click the ‘-’-sign or press Delete.

Your logbook

You can use Cheetah as a logbook to keep track of the following time-stamped information:

glucose level

insulin dose

food intake

health status are you in good health or do you suffer from an illness (e.g. flu)

stress level

activities e.g. sport

weight a couple of times per year, you will adjust your weight value. 
your weight will be used to calculate your body-mass index 
(BMI), helping you to tune into your ideal weight, depending 
on your age and height.

comment any comments you may want to add; many use this to enter 
diary remarks

Use the logbook to:
• easily view a results and an average of results over a given period;
• view results in chronological order along with the time and date;
• view the average value, the standard deviation and the number of results for the complete 

period selected and for all the time periods separately.;
• view highlighted results that fall above or below the low or high watermarks;
• switch between expanded or compact form; when set to expanded the logbook will display 

multiple results on the same day in the same period; when set to compact, the logbook will 
display only the latest result of the time period.
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Time-stamped entries

As soon as you enter new information or make changes, a time stamp is automatically added to 
your information. This allows you to later create comprehensive graphs and analyze your diabetes 
history.

TODO Future versions of Cheetah will allow you to discard any old data in order to save space.

TODO We need some guestimates on how much data is collected over the life time of an individual 
(say 100 years). Next, check if this is a prohibitively large amount of data and a way to reduce 
the amount if necessary.

Navigating, sorting and editing cells in your logbook

To rearrange the order of the displayed columns:

  Drag the column headers to the left or right.

To adjust the width of columns:

 Drag the separator lines between the column headers. 

Most of the columns can be sorted in ascending or descending order.

To sort the entries in a column:

 Click the sort arrow in the right hand side of the column head.

The arrow in the right hand side of the column head will show the current sorting order (up for 
ascending and down for descending).

To switch between ascending and descending order:

 Click the sort arrow in the column head again.

You can show or hide various columns. A check mark to the left of the column name indicates if 
the column currently is shown or hidden.

To show or hide columns:

 Choose View > Columns, and choose a column.

When you have been using Cheetah for a while, you will have collected quite some data and the 
data pane will show many entries. To limit the number of entries in the data pane, you can use 
autofiltering.
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Filtering is a quick and easy way to find and work with a subset of entries in a list. A filtered list 
displays only the rows in a column that meet the criteria you specify. Unlike sorting, filtering does 
not rearrange a list, but instead temporarily hides the rows you do not want displayed.

When you use the AutoFilter command, AutoFilter arrows appear to the left of the column labels 
in the filtered list.

A check mark to the left of the AutoFilter command indicates if autofiltering is turned on or off.

To toggle autofiltering:

 Choose View > AutoFilter.

To limit the number of visible entries in a column:

 Click the AutoFilter (left hand) arrow in the column head and select the item on which to filter.

Clicking an AutoFilter arrow displays a list of all unique, visible items in the column, including both 
blanks (no entry in a cell, or an entry that is all spaces) and nonblanks. By selecting an item from 
the list for a specific column, you can instantly hide all rows that don't contain the selected value 
in that column. The AutoFilter arrows turn orange in each column that contains the selected 
value.

Navigating your logbook

You can navigate through the cells in your logbook using the arrow, Return and Tab keys on your 
keyboard. The arrow keys move the selection left, right, up, and down. The Return key moves the 
selection down one cell, and the Tab key moves the selection up one cell. Pressing and holding the 
Shift key in combination with Return or Tab key reverses the direction.

Making Changes

Cheetah supports in place editing. For example, to change any value, select the cell and press F2 
on Windows or Control-U on the Mac. You can also double-click a cell in order to make changes. 
This sets the insertion point and you can start typing.

To add a logbook entry

1 Click the ‘+’ in the lower left of the main window to move to a new empty row at the end of your 
data. Note that a time stamp is automatically added to the new entry. You can always change the 
time stamp later.

2 Enter values in the relevant columns and press Enter.

To remove a logbook entry

 Select the row and press Delete.
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To replace a cell’s contents

1 Click the cell that contains the data you want to replace. The cell becomes selected.

2 Start typing the new contents. This will replace the existing contents.

3 To enter your changes, press Return or Tab.

You can also use the arrow keys to navigate up, down, left, and right across cells.

To Edit a Cell’s Contents

1 Double-click the cell that contains the data you want to edit to set the insertion point.

2 Make any changes to the cell contents.

3 To enter your changes, press Return or Tab.

To cancel your changes, press Escape.

When you double-click a cell to edit it, the arrow keys work only within that cell. To use the arrow 
keys to move to another cell, first press Return or Tab to complete your editing changes to the 
active cell.
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2 Excellent Offline Behavior

With Cheetah, any change you make can be seen by online peers within a few minutes, provided 
you both share the same view. For example, if John and Mary are both online and view the root 
community, and John creates a new community named “Orange” within the root community, 
Mary will see the “Orange” community appear as well within a few seconds.

TODO The question if John pushes or Mary pulls the information remains to be decided. Martien will 
write a short story (scenario) before the end of March that details the overall design and 
behavior of this synchronizing, mirroring system, as well as some architectural considerations, 
balancing CPU, disk space and network traffic requirements.

Zero Maintenance

The end result is that all the information you manage is kept persistent on multiple distributed 
peers. This removes the need for specialized backup and persistency servers and improves 
reliability, availability, and scalability at an extremely low cost.

Feed and Grow Your Community, wake up the Big Friendly Giant

To bootstrap small communities with just a few peers while assuring reliable availability of 
information, consider dedicating one or two machines as caching peers. These machines often 
have somewhat more computing power, bandwidth and disk space available and are connected to 
the internet around the clock. You can run a standard instance of Cheetah with the ‘caching peer’ 
option turned on. We tend to call a configuration like this a Big Friendly Giant or BFG for short.
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3 Registration and Login

Registration

When you start Cheetah, the main window opens and you can search and browse any publicly 
available information. You cannot make any modifications however.

Before you can create, update or delete information in Cheetah  you need to login with your user 
account and password. If you don’t have an account, you will need to create one. User accounts 
and passwords are encrypted before they are send over the network to keep your personal 
information safe at all times.

TODO How can you both be absolutely sure your data is anonymous and be able to restore your own 
data? This is a challenge for the development team. Perhaps needing a separate discussion.

To register a new account:

TODO The steps below are just a placeholder for the actual way registration will work. Still needs to be 
worked out.

1 Choose Cheetah > Create New Account. Cheetah will show the Account dialog.

2 Enter your name, e-mail address, user name and password. Enter your password again for 
verification.

3 Click the Information icon and read and accept the Cheetah  End User License Agreement.

4 Select the checkbox labeled ‘I accept the End User License Agreement’.

5 Click ‘Create Account’. The registration process is started and you will receive a confirmation e-
mail within a few seconds.

6 Click on the link in the body of the e-mail message to activate your registration. You can now 
login.

The e-mail contains your account name that you can use to login. Keep a copy at a safe place for 
later use. For security considerations, your password is not included in the e-mail message.

Login

To login:

1 Choose Cheetah > Login. Cheetah will show the login dialog.

2 Enter your user name and password and click ‘Login’.
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Cheetah ’s main window appears. Your identity is displayed in the status bar. Cheetah supports 
multiple identities. For example, you can set up an identity for personal use and one for 
professional use. To switch to another identity, simply login again, using the desired identity. To 
log out, choose Cheetah > Sign Off.
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4 Search and Find
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5 Communities

In Cheetah, “community” refers to any self-defined group of people. So nations, speakers of a 
particular language, religions, companies, families, social groups and interest groups are all 
considered “communities” in the context of Cheetah.

You can invite others choose Help > Invite a Friend. Cheetah will send an invitational e-mail to 
your friend similar to the one you received.

Community Management

You can manage communities by setting the community membership policy, sharing management 
responsibilities with others, and removing members or publications from a community, or by 
removing the community altogether. 

Community Membership Policies

Create a Community

To create a community:

Change Community Properties

To change community properties:

Join a Community

Before you join a community, complete and review your personal profile. You must be logged in to 
join a community.

To join a community:

Unjoin a Community 
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To unjoin a community:

Remove a Member from your Community

To remove a member from your community:

Change the Community Membership Policy

To change the community membership policy:

1
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6 Sharing your data with peers

Cheetah makes it easy to share data with peers, either on a global level or within a community 
and its sub-communities

Exporting data to external files

TODO Export to XML, RDF, CSV, plain text.
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7 Managing Cheetah

Recovering from Data Loss

Since Cheetah is a pure peer-to-peer system, multiple copies of some or all of the data is available 
at peers across the network. And if the network has one or more Big Friendly Giants (caching 
peers) configured, all data will be available at those peers as well.

To recover from data loss:

1 If needed, download and install Cheetah.

2 Next, login, and after a few minutes, most if not all metadata will be locally available again.
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